A == B ?

发布时间: 更新时间: 总字数:182 阅读时间:1m 作者: IP上海 分享 网址
专栏文章

    A == B ?

    Problem Description

    Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

    Input

    each test case contains two numbers A and B.

    Output

    for each case, if A is equal to B, you should print “YES”, or print “NO”.

    Sample Input

    1 2 2 2 3 3 4 3

    Sample Output

    NO YES YES NO

    源码

    #include <stdio.h>
    #include <string.h>
    
    void A( char *s )
    {
        int len = strlen( s );
        char    *p  = s + len - 1;
        if ( strchr( s, '.' ) )
            while ( *p == '0' )
                *p-- = 0;
        if ( *p == '.' )
            *p = 0;
    }
    
    
    int main( void )
    {
        char    *pa, *pb;
        char    a[100024], b[100024];
    
        while ( scanf( "%s%s", &a, &b ) != EOF )
        {
            pa = a; pb = b;
            while ( *pa == '0' )
                pa++;
            while ( *pb == '0' )
                pb++;
            A( pa ); A( pb );
            puts( strcmp( pa, pb ) ? "NO" : "YES" );
        }
    
        return(0);
    }
    
    Home Archives Categories Tags Statistics
    本文总阅读量 次 本站总访问量 次 本站总访客数