A == B ?

发布时间: 更新时间: 总字数:182 阅读时间:1m 作者: 分享 复制网址
专栏文章
  1. 1000 A + B Problem
  2. 1001 Sum Problem
  3. 1002 A + B Problem II
  4. 1003 Max Sum
  5. 1004 Let the Balloon Rise
  6. Presentation Error
  7. Who Won The Duel?
  8. 让气球升起来
  9. 1005  Number Sequence
  10. A == B ?(当前)

A == B ?

Problem Description

Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input

1 2 2 2 3 3 4 3

Sample Output

NO YES YES NO

源码

#include <stdio.h>
#include <string.h>

void A( char *s )
{
    int len = strlen( s );
    char    *p  = s + len - 1;
    if ( strchr( s, '.' ) )
        while ( *p == '0' )
            *p-- = 0;
    if ( *p == '.' )
        *p = 0;
}


int main( void )
{
    char    *pa, *pb;
    char    a[100024], b[100024];

    while ( scanf( "%s%s", &a, &b ) != EOF )
    {
        pa = a; pb = b;
        while ( *pa == '0' )
            pa++;
        while ( *pb == '0' )
            pb++;
        A( pa ); A( pb );
        puts( strcmp( pa, pb ) ? "NO" : "YES" );
    }

    return(0);
}
Home Archives Categories Tags Statistics
本文总阅读量 次 本站总访问量 次 本站总访客数